Selasa, 01 April 2014

Layer 7 Protocols Mikrotik

Catatan Pengingat Tentang Layer 7 protocol  Audio, Video, Youtube, Download Ekstensi, dan Download FTP

## Testing Di Router OS 5.26


Layer 7 Protocol 

/ip firewall layer7-protocol
add name=Video regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\
    \\x09-\\x0d -~]*(content-type: video)"
add name=Ekstensi regexp="\\.(exe|rar|zip|7z|cab|asf|mov|wmv|mpg|mpeg|mkv|avi|\
    flv|pdf|wav|rm|mp3|mp4|ram|rmvb|dat|daa|iso|nrg|bin|vcd|mp2|3gp|mpe|qt|raw\
    |wma|ogg|doc|deb|tar|bzip|gzip|gzip2)"
add name=Youtube regexp="o-o.preferred.pttelkom-|a.youtube.com|b.youtube.com|c\
    .youtube.com|d.youtube.com|e.youtube.com|f.youtube.com|g.youtube.com|h.you\
    tube.com|i.youtube.com|j.youtube.kom|l.youtube.com"
add name=Audio regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\
    \\x09-\\x0d -~]*(content-type: audio)"
add name=FTP regexp="^220[\\x09-\\x0d -~]*ftp"



Mangle Rule

/ip firewall mangle
add action=mark-packet chain=forward comment=Ekstensi disabled=no \
    layer7-protocol=Ekstensi new-packet-mark=Ekstensi passthrough=no \
    protocol=tcp 
add action=mark-packet chain=forward comment=FTP disabled=no layer7-protocol=\
    FTP new-packet-mark=FTP passthrough=no
add action=mark-packet chain=forward comment=Youtube disabled=no \
    layer7-protocol=Youtube new-packet-mark=Youtube passthrough=no protocol=\
    tcp
add action=mark-packet chain=forward comment=Video disabled=no \
    layer7-protocol=Video new-packet-mark=Video passthrough=no protocol=tcp



Langkah Selanjutnya Bisa di teruskan Ke Que Tree ato Que Simple Sesui kebutuhan dan kondisi Di jaringan Anda

Twitter Facebook Digg